Error running pod install .Error launching application on iPhone 12 Pro Max.

WechatIMG144.png

  • 首先检查 pod install 可不可以运行,我这里报错了

WechatIMG181.png

  • 然后 运行 sudo gem install ffi 成功运行

WechatIMG199.png

  • 继续 pod install 还是报错 ,先确认是否安装了 cocoapods,如果没有安装需要先安装,如果安装了, 在iOS 目录下
    的podfile文件中添加source源

WechatIMG204.pngWX20201203-101602.png

    source 'https://cdn.cocoapods.org/'
    source 'https://github.com/aliyun/aliyun-specs.git'
    pod 'AlicloudPush', '~> 1.9.9'
  • 然后执行 pod install 启动项目,出现了另外一个错误 如图
    WechatIMG247.png

Could not build the application for the simulator. Error launching application on iPhone 12 Pro Max.

  • 再修改下podfiel里面的 post_install

WX20201203-102251.png

 post_install do |installer|
   installer.pods_project.targets.each do |target|
     target.build_configurations.each do |config|
         config.build_settings['ENABLE_BITCODE'] = 'NO'
         config.build_settings.delete 'IPHONEOS_DEPLOYMENT_TARGET'
         # config.build_settings['IPHONEOS_DEPLOYMENT_TARGET'] = '13.6'
         config.build_settings['SWIFT_VERSION'] = '4.1'
      end
   end
end
  • 再启动~~~成功啦!!!
Last modification:December 3rd, 2020 at 10:52 am
如果觉得我的文章对你有用,请随意赞赏